Jump to content

- - - - -

"System ERROR" on FX-9860GII SD PC=8801BFB8

FX-9860GII ; System Error;

  • Please log in to reply
5 replies to this topic

#1 oldironman



  • Members
  • Pip
  • 3 posts

  • Calculators:

Posted 28 February 2019 - 11:27 AM

Hi everyone!


I am new here and need some help. :-)


After programming a lot of navigation functions and using my FX-9860GII SD for many years, I didn't use it for a while.

Now I replaced the batteries but can not use the calculator anymore. Local service center is unable to help.

When turning the calculator on I get the message: (I still can turn it on/off)


System ERROR




 TARGET = 0014004F

 PC          = 8801BFB8


Apparantly the boot doesn't go the right way and stops at the above address.

The message itself is not documented, neither what am I supposed to do about.

The addresses could help to anyone who has the compiled system source and the loading map to figure out the reason.


If I wait more than 10 minutes I might get into service mode by pressing and holding OPTN + EXP + AC/on

Tests run OK.


If I hook up the calculator (OFF)  to the PC, the communication menu shows on the screen.

But there is no way to connect to the FA-124 program. The program jumps to the above error message.


Is there any way to completely reload the flash memory via USB without the bootstrap which is apparently damaged?



#2 Raresh Nistor

Raresh Nistor


  • Members
  • Pip
  • 5 posts
  • Gender:Male
  • Location:Middle Earth
  • Interests:* Software Development
    * Design and Photography
    * Linguistics

  • Calculators:
    * CASIO fx-9750GII MkII

Posted 01 March 2019 - 02:36 AM

I don't know how much help this will be, but on top of the service mode, there's also an OS recovery thing if you press a sequence of keys on startup. I found this out when I was flashing the fx-9860G firmware on my fx-9750GII.


If you can get your hands on a stock flash image for your calculator, you might be able to reflash it to factory settings. The detailing the flashing of my calculator hopefully point you in the right direction.

Reflashing your calculator should be your last resort if nothing else works ????‍♂️. Good luck, hopefully you can get some more use from that calculator.

#3 oldironman



  • Members
  • Pip
  • 3 posts

  • Calculators:

Posted 01 March 2019 - 09:32 AM

Hi Raresh,

thank you for the rapid response!


Now I can not get back to the service menu at all, even if I wait half a day. This doesn't allow to get the OS version currently loaded. When it was still possible I didn't write it down. :-(


Did you mean by RESET button the RESTART button on the back of the calculator?


It is tricky to press and hold keys on both side of the calculator:-) I tried and cramped up.


I'll have to find the right tool and the flash image. Then I'll try to get the OS installed, because I don't see other way to save the calculator.


I'll post what I achieved.

#4 GodOfCows


    Casio Addict

  • Members
  • PipPipPip
  • 79 posts
  • Gender:Male

  • Calculators:
    fx-9860gii, fx-9750gii, TI-92, TI-89, TI-83 Plus

Posted 01 March 2019 - 03:39 PM

Have you not yet just pressed the reset button on the back of the calculator while it was on? Flashing a new OS can be risky. Ill look up what the address is later.

#5 oldironman



  • Members
  • Pip
  • 3 posts

  • Calculators:

Posted 01 March 2019 - 06:30 PM

I've pressed the RESTART button, after there was no way to get around the "System ERROR" message. Since I had backed up all my programs on the PC I didn't judge it risky to lose anything I developed.


The factory flash image should be available to be reloaded on any decent computer, which the calculator in fact it is.


What gives me a bad feeling, that ever since I have tried to get the calculator up, it responded with different behavior:


first I could get to the service menu,

then I had to wait several minutes with the calculator off to achieve the same

and now I can not get to the service menu at all, no matter how long the calculator is OFF.


I bet, there is an electrolyte condensator inside, pulling the voltage down. I'll have to check the voltage on the PC board, eventually change the elco to see what happens. The "imposed" delay let me think about the condensator discharge time that effects the operation.

By the way this calculator doesn't have backup battery.

#6 sentaro21


    Casio Technician

  • Members
  • PipPipPipPipPipPip
  • 369 posts
  • Gender:Male
  • Location:JAPAN

  • Calculators:
    FX-603P fx-4800P fx-5800P
    CFX-9850GC PLUS
    fx-9860GII-2 SD
    HP 50G
    TI-Nspire CX CAS

Posted 02 March 2019 - 03:04 AM

Could you try this OS update process?
F2+4+AC/on+RESTART ,9, :x:

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users