Jump to content



Photo
- - - - -

Weird Definite Integral answer fx-991EX


  • Please log in to reply
1 reply to this topic

#1 bdanny55

bdanny55

    Newbie

  • Members
  • Pip
  • 1 posts

  • Calculators:
    fx-991EX

Posted 26 March 2019 - 03:23 PM

Hello all!

 

Just joined because I'm going through integration and was checking my answers on my new fx-991EX.

 

I input the following: 10x(x^(1/2)-2) between 0 and 4 (with the integration button, of course).

 

The first weird thing was that it took far longer than it usually takes, and secondly, the answer it gives is: -32.00000017 :blink:  when doing it by hand the answer is simply -32.

 

I downloaded the emulator for this calc and it gives the same answer. I tried both degrees and radians with the same result.

 

I'm mostly just curious why this happens if anybody knows.

 

Thank you!



#2 pan.gejt

pan.gejt

    Casio Freak

  • Members
  • PipPipPipPip
  • 192 posts
  • Gender:Male
  • Location:CZ

  • Calculators:
    .

Posted 27 March 2019 - 07:09 AM

I don't know what you mean by "weird result", because the difference 1.7×10^-7 is not really weird result. 

Generally spoken, you shouldn't expect exact results achieved by any numerical methods and don't mix such methods with exact analytic solutions.

Back to your example, the default tolerance is 1×10^-5 but you can change it. I used tol value 1×10^-6 and the result is -32.

On the other side, exceptionally you need to set the tol value looser.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users