Jump to content

- - - - -

Programs crashing on fx-9860GIII

  • Please log in to reply
2 replies to this topic

#1 Paddie808



  • Members
  • Pip
  • 1 posts

  • Calculators:

Posted 31 October 2022 - 07:22 PM

I recently got a CASIO fx-9860-GIII and have decided to install some addons. So far, the only files that give any result are .g1a s (are these the only supported file types or am I just being stupid?), and except from some official CASIO ones, all of the ones i have tried have crashed and frozen the calculator, meaning i have to use the reset button. Is there any way to prevent this?


Thanks so much for any help!

#2 HappyCalc


    Casio Addict

  • Members
  • PipPipPip
  • 67 posts
  • Gender:Male
  • Location:Germany
  • Interests:Programming, On-Calc Programming(C.Basic), Gaming, Origami, Eating Chocolate

  • Calculators:

Posted 19 February 2023 - 06:20 PM

The problem is probably, that they are for an older version of the CPU (the SH-3), you have the SH-4. Try to find an SH-4 compatible version. There are also some incompatibilities between the GII and GIII, but i didn't see many GIII versions of the programs.

#3 Fegolix



  • Members
  • Pip
  • 3 posts
  • Gender:Male

  • Calculators:
    fx-9860 GIII

Posted 19 February 2023 - 09:15 PM

I only have the fx-9860 GIII and use the GII SDK and it works fine. HappyCalc is completly right most of the programs are written for the SH-3 CPU and therefore doesn't work. But so far every G1A I compiled with the SDK worked on my GIII with SH-4 CPU.


The only other option of writing programs on the calculator are CASIO BASIC programs(.g1m). 

You can edit them on your calculaor or use BIDE from Planete Casio.



If you want to check out my GIII programs, I publish them on my GitHub.


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users