Jump to content



Photo
- - - - -

fx-CG50 memory error

fx-CG50 memory programming

  • Please log in to reply
2 replies to this topic

#1 Dishwasher

Dishwasher

    Newbie

  • Members
  • Pip
  • 2 posts

  • Calculators:
    CASIO fx-CG50 graphic calculator
    CASIO fx-82MS scientific calculator

Posted 07 September 2020 - 06:55 PM

i was busy making a game with CASIO BASIC when i got a memory error, now all of my programs result in that error, even the ones not connected to the game at all. i got this error once before, and accidentally fixed it while i was packaging the game up for some of my friends, in order to check if everything worked i removed removed all of my programs that had to do with the game, and put them back through txt files. what causes this error and is there any way to fix this?

 

also, this is just an extra question, is there any way to make an actual save file, because right now i'm using matrixes to save any game data and the only thing stopping people from wiping it is that people barely use the matrix in my friend group



#2 Lephe

Lephe

    Newbie

  • Members
  • Pip
  • 16 posts

Posted 09 September 2020 - 06:01 AM

As far the save file is concerned, there is no known way of saving data that can't be erased by normal use of the default applications. You can store list data in a different file (File 2 to File 6) and go back to File 1 at the end of the program, since barely anyone uses this feature - but it will just be more hidden.



#3 HappyCalc

HappyCalc

    Casio Addict

  • Members
  • PipPipPip
  • 57 posts
  • Gender:Male
  • Location:Germany
  • Interests:Programming, On-Calc Programming(C.Basic), Gaming, Origami, Eating Chocolate

  • Calculators:
    fx-9860GII-2
    fx-CG50

Posted 16 January 2022 - 09:21 AM

You may check if a string contains an unallowed letter. I have just saved a string to .g1m edited it in a hex editor and reloaded it. I wanted to let it contain any byte (0-255) to be able to get any byte using StrMid. After loading the Tsring from the g1m, MemoryErrors started to appear randomly in some programs. The i checked every character if it causes the problem. My result was that 0x84 and 0x94 cause these problems. Maybe there is such a character in a string or in the program code.





Also tagged with one or more of these keywords: fx-CG50, memory, programming

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users